node.js - پس از بهروزرسانی نمیتوان هیچ بسته Angular را پیدا یا نصب کرد


دیروز Angular را به 11.2.14 ارتقا دادم. Angular را با راهنمای Angular بهروزرسانی کردم و از دستور ng update @angular/cdk@11 @angular/cli@11 @angular/core@11 @angular/material@11 استفاده کردم. بعد از اجرای این دستور، نصب بستهها زمان بسیار زیادی طول کشید.

بعد از ۴۵ دقیقه دستور ng update را لغو کردم و میخواستم نصب بستهها را بهصورت دستی با npm install امتحان کنم. متأسفانه npm install همانطور که انتظار داشتم کار نمیکرد.

npm install به من خطای زیر را میدهد

npm ERR! While resolving: [email         
npm ERR! Found: @angular/[email 
npm ERR! node_modules/@angular/cdk
npm ERR!   @angular/cdk@"^10.2.7" from the root project

وقتی من تلاش میکنم npm install @angular/cdk@11 همان خطا را دریافت میکنم وقتی که تلاش میکنم npm install

من هم همان خطا را در Angular material، core، common، compiler و animations دریافت میکنم. من نسخههای مختلف نود را امتحان کردهام، کش npm را پاک کردهام، پوشه node_modules را حذف کردهام و فایل package-lock.json را نیز حذف کردهام. هیچکدام از این کارها به نظر نمیرسد که کار کنند.

پکیجهای Angular در package.json

"@angular/animations": "~11.2.14",
"@angular/cdk": "^10.2.7",
"@angular/common": "~11.2.14",
"@angular/compiler": "~11.2.14",
"@angular/core": "~11.2.14",
"@angular/fire": "^6.1.4",
"@angular/flex-layout": "^10.0.0-beta.32",
"@angular/forms": "~11.2.14",
"@angular/localize": "^11.2.14",
"@angular/material": "^11.2.13",
"@angular/platform-browser": "~11.2.14",
"@angular/platform-browser-dynamic": "~11.2.14",
"@angular/router": "~11.2.14",

در زیر خروجی دستور ng --version آمده است. میدانم که نسخه Angular CLI با خود Angular همنسخه نیست، اما حتی وقتی Angular نسخه 11.2.14 بود، خطاها همچنان رخ میدادند

Angular CLI: 11.2.14
Node: 14.17.1
OS: win32 x64

Angular: 12.0.5 (cli-only)
... common, core
Ivy Workspace: Yes

Package                             Version
-------------------------------------------------------------
@angular-devkit/architect           0.1102.14
@angular-devkit/build-angular       0.1102.14
@angular-devkit/core                11.2.14
@angular-devkit/schematics          11.2.14
@angular/animations                 <error>
@angular/cdk                        <error>
@angular/cli                        11.2.14
@angular/compiler                   <error>
@angular/compiler-cli               <error>
@angular/fire                       <error>
@angular/flex-layout                10.0.0-beta.32
@angular/forms                      11.2.14
@angular/language-service           11.2.14
@angular/localize                   11.2.14
@angular/material                   <error>
@angular/platform-browser           11.2.14
@angular/platform-browser-dynamic   11.2.14
@angular/router                     11.2.14
@schematics/angular                 11.2.14
@schematics/update                  0.1102.14
rxjs                                6.6.3 (cli-only)
typescript                          4.0.8

npm install --force یا npm install --legacy-peers گزینه نیست زیرا پکیجها نصب نخواهند شد (و هر دو دستور خطا میدهند که نمیتوانند پکیجهای Angular را پیدا کنند)

چطور میتوانم خطا را برطرف کنم؟

بهروزرسانی من یک پروژه جدید ایجاد کردهام و وابستگیها را در package.json جدید کپی و جایگذاری کردهام. بعد از اجرای npm install همان خطا را دریافت کردم. من فکر میکنم این خطا در محدوده جهانی رخ میدهد و فقط محدود به پروژه نیست. مطمئن نیستم که Angular چگونه undefined را میدهد.

ng --version جهانی

Angular CLI: 12.0.5
Node: 14.17.1
Package Manager: npm 7.17.0
OS: win32 x64

Angular: undefined
...

Package                      Version
------------------------------------------------------
@angular-devkit/architect    0.1200.5 (cli-only)
@angular-devkit/core         12.0.5 (cli-only)
@angular-devkit/schematics   12.0.5 (cli-only)
@schematics/angular          12.0.5 (cli-only)

بهروزرسانی به نظر میرسد Angular یک ´´´""´´´ اضافه میکند. این ´´´""´´´ اضافی از کجا میآید؟